Issues with audio

Is anyone else having issues with audio not playing? I’m using the Genki and 10k decks and over the past two days I’ve had issues with audio. Audio plays for some words and not others, there doesn’t seem to be any consistency for when audio will play and when it won’t. I’m ending up with 30 or 40% success rates coming out of my reviews :anguished:

I’ve tried clearing the kitsun cache and my browser cache but nothing’s working.

1 Like

Hi @livelytania! I’ve also seen your email about the problem but figured I could reply here as well:

I haven’t changed anything related to audio lately for Kitsun so I’m not sure where the problem is coming from. There are many possible factors in play so perhaps we can start by eliminating them one by one:

  • Do you use autoplay for audio or do you click the button manually?
  • What device are you using? Does this also happen on other devices?
  • Does this happen on the website or on the mobile apps (or both?)
  • Does this happen on specific layouts?
  • Are you certain the audio used to always play for those layouts/cards?
  • In your deck settings, do you have audio autoplay on for both the back and the front side? Two toggles
  • Perhaps @hinekidori (the author of the deck) made a layout or card content change causing this?
  • When the audio does not auto play, do you see an audio button somewhere on the card? What happens if you click it?

Hope we can get to the bottom of this and fix it asap :slight_smile:

In any case, sorry for the inconvenience!

Hi @Neicudi thanks for getting back to me! I wonder if anyone else has had these issues before? Maybe only me…

I’m still having the problem today. I seem to be able to get halfway through a set of reviews (86 today) with audio working fine, and then it starts to get dodgy with may soundclips not playing.

Anyway, here are the answers to your questions:

  • I use audioplay. When audio doesn’t work I’ve tried manually pressing pause and play again, but nothing happens.
  • Macbook Pro
  • Website (I haven’t tried mobile or mobile app so not sure if the same thing is happening there)
  • Layouts…not sure what you mean here. I’m having the problem with both Genki and 10K decks.
  • Yes the audio used to always play. I started using kitsun earlier this year. I’ve been doing daily lessons and reviews for months (I’m level 18 or 19), never had this issue before.
  • I’ve checked deck settings and for both Genki and 10K I have: auto play front ON, auto play back OFF. Not entirely sure what the difference between the two settings is…
  • I doubt it’s an issue with @hinekidori 's deck because I’m having the issue in two different decks (Genki, 10K)
  • When the audio does not play I see a ‘pause’ button on the screen. If I click it, it toggles to a ‘play’ button. If I click it again it toggles back to a ‘pause’ button but I still don’t hear any audio.

Hope this helps! Hopefully we can get to the bottom of this as it’s seriously slowing down my reviews!


1 Like


Going to take a look and hopefully resolve it ASAP. If possible could you please let me know on which card(s) the audio seems to get stuck?

The audio being an issue on multiple decks could be the case of hinekidori updating the layouts (he made both the decks you are using), but I’ll let you know once I figure it out!

Just a thought, when the pause button is being showed it means that the audio should be playing or it’s loading :thinking: Not sure if you’ve tried waiting, I sometimes have to wait for around 20 seconds if my internet is not as stable.
Hopefully it will get solved soon :smile:

Yes, when I saw the pause button still showing I tried waiting. I’ve noticed in the past that when my wifi is slow the audio can take a while to play. But in this case I’ve waited minutes and no audio.

1 Like

Sorry to bug you, but after seeing this thread I decided to try disabling my network adapter after loading a deck* to simulate a disconnect. If I stay disconnected when loading a card with audio + autoplay on I get the same behavior where clicking pause/play does nothing and gives me the error quoted below. The problem persists even after reconnecting, but the next card that plays audio is fine if I’m connected. I don’t really think autoplay has anything to do with it, I disabled autoplay experienced the same behavior. It seems as long as I’m disconnected when the card changes to the side with the clip to play the audio will stay bugged for that item. I’d test this more, but dinner is probably burning.

  • Tried manual audio and disconnecting after loading the back side, worked fine.
  • Disconnecting before front side of new card and staying disconnected was busted.
  • Disconnecting before front and reconnecting before the back side was fine.

* I’m using the big Katakana deck initially

Uncaught (in promise) DOMException: The play() request was interrupted by a call to pause().

Extended testing on JLPT N5 deck.

I saw the same behavior as above, with some changes presumably due to however shared data is handled for siblings.

If one sibling loads the audio it won’t be broken even if disconnected from the internet with the second sibling. However, if the first sibling gets bugged audio it will still load on the second sibling.

Minor issue? Probably known


I had about 80 reviews from 10K to do and about 40 reviews from Genki this morning. Here are the words the front audio got stuck on (I’ve turned on back audio and it seems to play fine on these same words).

But I don’t think it’s these specific words that are the problem. When I start to do reviews everything seems fine, it’s only towards the end that I start having problems with audio. So you can see that I got through all but one review in the 10K with no audio issues. When I then started the Genki reviews I started having a lot more issues.

I’m not a developer but let me know if there’s anything I can do to help figure this out…would looking in Inspector > Network when I encounter the problem give you any useful info?

10K Deck:


1 Like

Thank you!

So far I’ve been unable to reproduce the issue, but I did receive a second report from another user through email, so there’s definitely something going on that affects multiple users.

It would be super helpful if you could do that! Ideally I’d love to see both the console messages (in the console tab, to check for errors/warnings) and the network calls for the audio. If the network call for the audio file failed, then it should turn red and clicking on it should show some additional information (e.g. why it failed and such).

Here’s an example of network call details that’d be super handy to see:

(Headers tab)

If it failed to load the status code should show a red circle instead.

I’m going to manually check the cards you mentioned now, will report back in a bit.


Can confirm that the cards’ audio play normally for me on the cards management page at least. @livelytania could you perhaps check 晴れる in the cards management page, click on the edit icon (pencil) and check if the audio plays for you when you click on the play buttons in the layouts?

Appreciate the help!

1 Like

Thanks for the help! The audio element on cards automatically loads the audio as soon as the html tag is rendered or when clicked, depending on the settings. There is no retry on the audio network calls as I did not expect anyone’s internet to be completely gone for such a long time that it would not load during reviews (if it’s just spotty internet, it should have a pretty long timeout time before it gives up).

Because of that I don’t think these problems are related, but it could be! We’ll know probably know more once we see the network calls.

I’m actually thinking it might be a CDN issue where the cache might have become corrupted for a specific region as both reports state it’s been happening since a few days and I don’t believe I’ve changed anything related to the audio playback during reviews. But this should become more clear once we see the calls.

1 Like

Think this will shed light on the problem!

Had a very quick google and sounds like Chrome has put a limit on number of audio tags that can be allocated in a particular tab. 75 for desktop browsers and 40 for mobile browsers.

This explains why the audio issues only start after I’ve been doing reviews for while.

So in theory I shouldn’t have this problem in a different browser?


Hrm, for what it’s worth, I started having this issue today on multiple browsers (Firefox/Safari) on multiple devices with the same Genki deck. I’ve allowed to auto play and back audio works perfectly, but I’m having audio issues completely. Not saying it’s a widespread problem, but was confused as I haven’t changed anything on my end.

1 Like

Just to follow on from this. I’ve just finished a ton of reviews in firefox with no audio issues. So the source of the problem for me has definitely been Chrome.

1 Like

Thanks again, that seems to be it yeah!

It seems like it broke quite a lot of websites/apps:

They’re saying that the next release will revert the limit changes and should be out on 3 august. As they are likely to limit it again in the future, I will be preparing some changes so that it will not be an issue in the future.

@tmhhn Could you open the console on firefox and let me know if any error shows? Or on the network tab as described above (should be similar on firefox).

What exactly do you mean with the back audio working perfectly but having audio issues completely? I’ll gladly look into it!

1 Like

:clap: :sweat_smile: So glad this we’ve figured this out! Making a big push to learn lots of vocab this month and this was making me want to pull out my hair :joy:

I’ll stick to Firefox until Aug 3rd.

Thanks @Neicudi for your help!

I’m not seeing any console messages other than the same logs that appear for other cards, like listing sibling cards. No network issues either!

Sorry, I think I was just very tired after work, I’m not even sure what I mean by “audio issues completely”. What I was trying to say is that, once I’ve answered a card the back audio auto plays perfectly fine, but every front card requires me to either hit the hotkey or press the play button.

Wondering if I messed up a setting somewhere? I haven’t touched anything, and I’ve tried toggling both the deck settings and the global settings to no avail. It’s weird that it’s happening to me on the browsers that don’t have the chromium issue on multiple devices!

1 Like

I’ve succesfully reproduced the issue and have added a failsafe that should fix this issue. The bugfix just went live so it should be resolved :smiley: Please refresh the page (if you had a tab open) and try again.

Please let me know if it still does not work for you!


Works perfectly now! Thanks for the fix!

As a software engineer, curious what it was, if you can share any details? If unable to for whatever reason I totally understand, just always curious about these sorts of things.

1 Like


Sure :smile:

The bug you were experiencing was caused by a check to see if the parent HTML element of the created audio element had a specific class for preventing autoplay (blur for spoiler blurring). Hinekidori made some changes to the layouts that caused the parent element to not have any class, so it returned as undefined and failed the condition to auto play the audio.

1 Like

I don’t use this deck but I happed to notice that alot of cards are wav instead of mp3 in the genki complete deck though there are mp3s as well. Just throwing it out there, I recall this was an issue in other decks.