Audio Not Playing On Reviews or Lessons

#EDIT: Never mind? Sorry to waste anybodies time but this seems to have resolved itself!

#EDIT 2: So it seems that this is an intermittent problem? It seems to fail some of the time even within the same review session. Could it be similar to this issues from the past? Audio issue


As of this morning audio on cards no longer plays for me. I am using the Japanese 10k kitsun Optimized deck. For reviews it simple shows the pause symbol as if it’s playing but it never does:

The same thing is true for lessons where clicking play changes the icon but it never actually plays:

To try to isolate this I’ve tried 2 different browsers on my desktop and 1 on my phone with the same result. I also tried getting the 5k french deck and it has the same issue with the first lesson:


This text will be hidden

When I look at the console I see that it does a successful Get request with status code 206 and if I go to that url for the audio directly it plays correctly: image

I don’t think this is that relevant but I also see that when I click the button again to pause the audio, the console also throws this:

Any help would be appreciated! Let me know if I can provide any more details.

1 Like

Hey @Agent007!

I’ve been making some changes regarding the audio files and how they are delivered from the server to the client. This was done in order to get .wav files to play on iOS files.

Does the problem still occur for you? You mentioned you tried different browsers and devices and it happens on those as well. What about if you refresh the page?

I tried the first card of the French 5k deck and it seems to work for me, so I’m thinking it might be unrelated to the change I made before, but rather an error with the code on the client.

Are your devices all apple devices by any chance?

Thanks for the detailed report by the way, that’s super helpful!

1 Like

Thanks for the update!

I’m using windows 10 on desktop and an android phone so likely no iOS related issues. I did try refreshing the page a few times with the console “Disable Cache” option enabled just in case. I wish I could give you a good example that consistently failed so you could test this better!

I just did 24 reviews and a few lessons and I had no issues again. When I tried doing my lessons in the morning at around 10:00 CST/ 16:00 GMT it wasn’t working at all. Then an hour or 2 later when I wrote up this post it started working about half the time. Now it seems to be back to normal.

If things start acting up again I’ll make another note. I’ve been actively using your site for around half a year at this point and it’s helping me out a lot so keep up the good work!

1 Like

Ah I see, then it might have been related to my above mentioned changes since I was working on that around that time iirc. Hope everything is good from now on!

Please let me know if it occurs again and I’ll take a look right away :slight_smile: Thanks again!

1 Like