Typing Kanji and other problems

I don’t know what’s going on but it seems like I can’t type much in this program without getting it wrong even though I cannot see what’s different between my answer and the right answer?

Kinda related but separate - I having trouble typing kanji here. like I switch to my hiragana keyboard, and then as I type I’m used to hitting ‘enter’ to solidify my words but here it just submits the answer and I get it wrong because I’m not finished typing my answer.

Does anyone have solutions or guidance to either issue?


1 Like

I just tried on the beta mobile app too and am having the same issues.

1 Like

Maybe the full stop is a problem? :thinking:


I also have the feeling that it might be related to the period behind your sentence combined with a deck setting that makes the spellcheck strict?

It might also have to do with your layout input field (e.g. a spellcheck input field). Could you let me know which layout you are using? Is it a custom one based on the defaults or is it just one of the default layouts in Kitsun?

Enter on your IME should not trigger the answer validation usually. I just tried it with the microsoft IME on windows and it does not trigger the answer validation but acts as it should (input the selected word) so that is kind of odd. Could you let me know which IME you are using? Is it the hiragana keyboard layout on iOS?

I’ll be happy to take a look!

I tried adding a Japanese period and it didn’t work. :confused:

Hi @Neicudi - thanks for helping me out here. For your first question, here is the layout setting I am using:

In regards to the ‘enter’ key issue, I am on MacOS and iOS, hiragana keyboard.

1 Like

@Neicudi - any ideas here? I really want to get back to my studying :frowning: but also totally understand you are probably very busy!

Is there a discord server for Kitsun.io?

1 Like


1 Like

He! Sorry, I completely forgot to reply! I’m currently on a small vacation but we can try to narrow the issue down a bit more.

Regarding the enter key issue, I do not currently have a mac device to test with, but I do have an iPhone, so I’ll try to replicate it and let you know!

For the other issue, could you try copying the correct answer from the backside of the card, clicking ignore answer/undo and pasting it in the input field to see if that works? I’ll also take a look on your account and check if I can find out whats causing the issue. Could you let me know which deck/cards the issue happens with?

Thanks for your patience!

Thanks for the response - and sorry to bother while you are on vacation. Please feel free to respond after you return.

In regards to what you asked—I just tried copying and pasting it from the back side of the card and it was still marking the answer as incorrect. The deck this is happening to me is in my “Grammar 2” deck.

Please let me know if I have any configurations wrong here - This is my first time making a deck that revolves around Japanese grammar and also kanji, so if there is a better format I could be doing I would love to know that.

Regarding the hitting ‘enter’ key issue, here is an additional screenshot that might help provide context:

As you can see when I type a word using the hiragana keyboard it tries to convert it to kanji but then I use the arrow (or space) key to navigate to the hiragana I want, but then to select it I need to hit ‘enter’…but when I do then it submits the answer at that point and I get it wrong.


1 Like

Sorry for the long wait. I’m back from vacation but was hit with food poisoning right before I went back home :frowning:

I’m going to check your deck right now to see what’s going on!

I’ll try to reproduce the enter issue again, but had no luck so far on iPhone. It is the standard iOS kana keyboard right? Anything special that’s activated (settings) or something?

1 Like

Found the problem that’s causing the answer to be marked incorrect. Have fixed it and will be pushing the fix with the next update (asap along with some other fixes).

1 Like

Awesome! Thanks @Neicudi :slight_smile:
When si that update set to go out?


Just for anyone else reading: The update went live fixing both problems :slight_smile:

1 Like