Site seems glitchy since yesterday

I’m having difficulty using the site since yesterday - the review sessions aren’t ending properly and it leaves me on a blank page. Also can’t end a review session part way through. Leaves me just having to shut down and re open the page. Anyone else having this?


Hi @Cathm2 !

Sorry to hear that, could you perhaps try to do a full refresh? (ctrl+shift+r or cmd+shift+r)

Yesterday a new update went out and if your Kitsun tab was still open it might need a manual full refresh.

I’m working on something to make this happen automatically in the future.

Please do let me know if it still does not work afterwards.

1 Like

How do I do that on an iPad? Sorry not very tech literate!

1 Like

I think there is no way to reliably do so on an iPad :sweat_smile: You mentioned that you had to re-open the page? It still does not work correctly after doing that?

Could you try to close all Kitsun tabs and afterwards opening it again to see if that works?

In the meantime I’ll check if anything is causing it to cache, as it definitely should not be doing this.

Tried all that, still not returning to usual page etc

1 Like

Hmm… I double-checked the caching headers and in theory it should be fine. Perhaps it is something else that is causing the problem.

If possible could you try to do the following:

  • Open incognito/private browsing, open kitsun there and check if it works well this time? (if so it’s likely caching)

Could you also let me know the OS version, browser you are using and device model? Does it happen with every deck (in case you use multiple) or just one? If one, which deck?


And sorry for the inconvenience, hoping to get to the bottom of this asap!

Just jumping in to say I’ve been having the same problems. Once I finish reviews there is no summary page but instead just a blank white one. refreshing the page does nothing, have to open Kitsun again in a new tab. Have done suggestions but it persists through restarts of my PC, full refreshing browser, and even in incognito mode.

Adding on that I’m using Edge and it appears reviewing in multiple decks.


I haven’t yet tried incognito mode (don’t know how) but is happening on both my ipad and also my laptop which I’ve tried to use for a hard reset. Laptop running Firefox, Ipad using safari. I did also try on a newer ipad and it did the same.

Not sure what to do from here?

1 Like

Thanks both, I think it’s clear that something else is acting up. I’ll try to reproduce it and fix it ASAP.

If any of you is able to, I’d really appreciate it if you could open the dev console and check for errors if it happens (F12/CTRL+Shift+i) on a desktop OS. That could help me narrow down the problem.

Regarding the blank page, can you see if it actually navigates the page or if it just stays? The url should change to something with “results” in it.

I noticed that you are both from the same region, so I think it might have something to do with a CDN location acting up. I’ve just purged the CDN to release any files in cache, so hopefully that does the trick.

I personally still haven’t been able to replicate the issue nor have I had any further reports from other users, so I’m starting to think that this might be it (your specific CDN location having a problem). Please let me know if after a refresh it still has this issue for you both!

1 Like

Seems to be fixed for me

1 Like

Still continuing for me, the results button in the top left seems to just not work either.
Once a review batch is completed it doesn’t change URL.
Dev tools gives me this error when batch finished as well as when attempting to press results button.

   Uncaught SyntaxError: Invalid or unexpected token


   ChunkLoadError: Loading chunk 21 failed.

at Function.o.e (app.343a2b42e2106884127d.js:1)
at rt (app.343a2b42e2106884127d.js:282)
at app.343a2b42e2106884127d.js:282
at app.343a2b42e2106884127d.js:282
at ()
at app.343a2b42e2106884127d.js:282
at ()
at Le (app.343a2b42e2106884127d.js:282)
at app.343a2b42e2106884127d.js:282
at p (app.343a2b42e2106884127d.js:282)

Tried with two decks, same error.
Hope that’s helpful

1 Like

Sorry to hear you’re still having issues

1 Like

Thanks! That’s definitely a caching problem, either on the CDN (my) side or on the client (your) side. As the CDN cache was purged this should not be happening anymore.

I’m going to deploy a new build and purge the CDN afterwards, hopefully that will completely fix your issue.

@Cathm2 Really happy to hear it was fixed for you at least, thanks for the patience!