I can't delete or edit decks (on my computer)

For some reason I can’t delete or edit any decks. Anyone knows why this is?
I can still do everything as normal on my phone (web app) so it’s not that inconvenient but I’d like to get this fixed if possible.

1 Like

Which decks are you trying to delete/edit? Are they community decks or personal decks?

I’ll check it out asap!

Hi, the problem has gone away by itself. I don’t think I did anything but it did persist for a few hours even after logging off and on and resetting my browser. I only tried to edit community decks as a test and none of them worked (on my pc).

1 Like

That’s definitely weird. I’ll run some tests and see if I can reproduce the issue.

But it is working correctly again? Judging by your screenshots the server did not return an actual error message which it usually should when it reaches the API. Meaning it probably errored out before reaching it or caused an uncaught error. I’ll go sift through the logs to see if I can find anything :slight_smile:

Sorry for the inconvenience, please let me know if it happens again somehow!

I’m having the same issue. Cannot delete or create decks.

Has been an issue for a few days now.

1 Like

On it! If possible could you check the console? (Press F12 and select the console) there might be an error there. Everything else works fine right? Like reviews and stuff?

It seems to be working for me so I’m not sure what’s going on without seeing some logs I think…

Well, the bug is gone now. Earlier today, after I posted, I was able to create and delete a deck. However, about ten minutes ago, I tried to delete a deck and was unable to. I then came on the forum, saw that you wanted me to check the console, went back and was again able to delete decks.

1 Like

Ah no worries, thanks for trying and sorry for the issues. I’ll keep on trying throughout the day.

If it happens again it would be great if I could see the console and the network tab, but if not then it’s no problem :slight_smile:

So far no luck with replicating the issue. If anyone else is experiencing this issue please let me know!

I’ve checked the logs and saw nothing weird in both the API logs and nginx (which forwards the requests) logs. So it looks like the network requests either didn’t get sent, or it failed to reach the server. One indicating a clientside issue, the other indicating a server issue.

All other interactions worked fine right? As in, you could do other things aside from this or did nothing work anymore?

Everything else worked fine.

1 Like

That makes it even weirder haha

FYI, I have some additional information. This problem has persisted intermittently and I have now stumbled across an additional(and I assume related) bug. Yesterday I navigated to"kitsun.io" and for some reason I wasn’t automatically logged on. I entered my name and password and recieved an error message. I figured the site was being worked on. Today, I tried again and got the same error message. So I naviagted to the message board instead and was able to go from the message board to “kitsun.io/decks” and I was logged in and everything was working fine.


1 Like

Here is the console readout:

Grammarly.js:2 [DEFAULT]: WARN : Using DEFAULT root logger
t.printToConsole @ Grammarly.js:2
Grammarly.js:2 [WARNING] Using default timeseries implementation.
e.getRootMetric @ Grammarly.js:2
static/site.webmanifest:1 Manifest: property ‘start_url’ ignored, should be same origin as document.
login:1 A cookie associated with a cross-site resource at https://m.stripe.com/ was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.

1 Like

login:1 Access to XMLHttpRequest at ‘https://api.kitsun.io/profile/login’ from origin ‘https://www.kitsun.io’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: The ‘Access-Control-Allow-Origin’ header has a value ‘https://kitsun.io’ that is not equal to the supplied origin.
14.b5a20f83a405ef788e8d.js:1 Error: Network Error
at LYNF.e.exports (app.7075fcc8fb82f6580a57.js:62)
at XMLHttpRequest.d.onerror (app.7075fcc8fb82f6580a57.js:267)
api.kitsun io/profile/login:1 Failed to load resource: net::ERR_FAILED
sw.js:3 Loaded service worker!

The “kitsun io” actualy has a period but I can only have 3 links in a post.

1 Like

The landing page was changed to a new design yesterday and does not automatically redirect you to your dashboard anymore in case you are already logged in. I’d recommend updating your bookmark (or similar) to https://kitsun.io/decks or /overview. This change was mostly done for SEO.

Looking at the logs I’m pretty sure I’ve figured out what the problem is for both issues! The url you are using is www.kitsun.io and not kitsun.io. I think I might have made a mistake with the whitelist and it is blocking requests coming from https://www.kitsun.io, but not https://kitsun.io. I’ve tried to edit a deck while on www.kitsun.io and it’s showing the same blank error notification as you both had.

Both urls should be working of course! I’ll go fix this right now!

Thank you so much for reporting this and showing me the logs! Sorry for the inconvenience!


Should be fixed now. Thanks again!

Very cool, thanks!

1 Like