Anki -> Kitsun Primer

Here is a breakdown of how I would import an Anki deck into one of my Kitsun layouts. I will be starting by importing into a preset template and then adjust accordingly.

  • First create a new deck.

  • From there go to import and select Anki -> Manual and drop in the Anki file.

  • From the dropdown select the deck created earlier.

  • Select the preferred Template. In this case I will be using one of mine.

  • A list of fields should be visible at this point. Here is how I would match up the fields in the sentence deck being used as an example. Notice that only three fields are needed in this case. The template was created as a one size fits all and therefore has a lot of extra fields that can be removed if wished.

  • Select the desired layouts then upload.

image

The deck has been successfully imported. From there you can go to the deck and confirm everything looks as you wish in Manage Cards.

In this case I selected my Sentence layouts, but if I wanted a text box I would select the Vocab layouts instead.

Below are how the fields and final result would be.

Note - It’s good to be aware that the furigana formatting is different between Anki and Kitsun. The sentences in the Anki deck used for this example has spaces that will cause the input box to fail if not removed.

Typically I would push the Anki deck to a CSV file and remove all the spaces en masse to adjust for this.

Also Kitsun does not currently ignore Japanese punctuation, so that would need to be typed or removed from the field.

5 Likes

okay so that work beautifully as a guide awesome stuff.
Only one thing I can’t figure out. How do I import the audio when I upload the CSV file?
I edited the CSV imported it back into anki and then exported it but the automatic import no longer works and when I start the manual import it gives me this page. The new apkg imports fine in anki.

1 Like

Thanks for taking the time to write this! :kithappy:

I assume you mean into Anki (and then into Kitsun)? If the audio is correctly referenced/working in Anki, it should import it automatically when doing an Anki import into Kitsun. I think it goes wrong in the Csv->Anki part?

@Neicudi i have definitely referenced the audio correctly. Thanks for all your help :slight_smile: I have attached the modified anki for you. It is working in Anki but when I try to import it manually, it gives me all of those options that I took a screenshot of earlier and when I do an auto import it doesn’t go past 0.

1 Like

Did you send the correct deck? When I run the import I only see two anki templates (“Basic” and “Sentences”).

It also only shows me “Front” and “Back” as template field options to choose from.

Yup its the correct deck just removed some stuff from it. Send you over the full one in a min. That’s the same problem i am getting on the kitsun import. But in anki it runs fine. This has all the data. But its the same problem. It keeps asking me to fill in front and back as template options.

1 Like

Ah gotcha, so upon some further checking, I do see additional options for the sentences template:

The audio imported correctly for me, by setting the “Audio” field to “Audio Sentence” (and not “Kana Audio”/“Kanji Audio”), but I’m not using the exact same target template as you are.

What I think is happening is that you have a basic anki template in the export as well, and that one only has Front and Back fields. When you scroll down to the bottom you will see the other templates that it wants to import (it should create a dropdown per anki template).

For the basic template I’d say to just set it to anything as it’s not actually being used I think. Otherwise you might want to check if you can delete the basic template from anki prior to importing.

Not quite sure what is going on. I simply just exported the original anki to text, opened it in excel saved as a csv. Deleted all the cards from the existing deck and imported in the modified csv.

I definitely do not see the kanji and english and audio options. Are you sure you are using the deck i sent you? I only see front and back.

1 Like

For anyone else reading this, we’re currently continuing this conversation on discord :slight_smile:

Bulk loading audio with a CSV doesn’t work if I’m not mistaken. I still just bring it back into Anki and do an apkg import.

Correct. This is because once the cards have been imported, there is no reference to the link that kitsun would generate with a batch media upload, so it won’t know which media file url on a card is linked to which media file url you just uploaded to kitsun’s hosting.

I think it might be possible if there is a batch media uploader in step 1 and step 2 has you specify the field that contains the value it would have to match in terms of filename or something… Quite error prone I think.

So we worked through all the bugs it seems.

  1. Do not use anki 2.1 or above.
  2. use anki 2.0.52 Anki 2.0.52
  3. Create an extra field for the index in your card deck where you index the cards in the order you want them to appear
  4. Deck is now published Deck link
2 Likes

Glad you figured it out. Anki keeps breaking stuff! :laughing:

1 Like

Couldn’t have done it without @Neicudi

2 Likes

Yeah, I’m sure @Neicudi really enjoyed debugging that :yum: