Anki Import broken

Currently unable to do the automatic import for Anki decks. Exported the .apkg then tried to import, it gets stuck “Creating deck” and throws an error in the Chrome Dev Tools. Same in Edge.


Thanks for reporting, I’ll take a look as soon as possible.

In case you tried multiple imports, does it happen with every anki deck or just this specific one?

Sorry for the inconvenience!

I only tried the one import, but it’s just a standard vocab deck using the default reversible cards and the new V2 scheduler in Anki options. I also tried the manual import instead of the auto, but couldn’t figure it out - the only option under every dropdown was “text” so it seemed like it wasn’t seeing the front vs back of the cards correctly.

Edit: Really i was just experimenting, i’m currently using the 10K deck to try out Kitsun but I was curious if I’d be able to import my Anki deck and retain the SRS levels in some form (even if just mapped to the closest default Kitsun level). I’m guessing it doesn’t do this and is just a vocab import method, but didn’t see any documentation in the knowledge base about imports.

1 Like

Tried another deck, no luck, same error.

It sounds like the note has no fields, is missing something or something is going wrong with the import in general. It’s supposed to show you a list of the fields used in anki.

I’ve tested the import and it seems to import decks well for me. Is there any chance you could send me the deck (or link the source) through PMs? I’d like to take a look at what’s going on. You mentioned it using a new scheduler, which might indicate that the internal structure has changed a bit :thinking:

It’s indeed just another way to import content for use inside Kitsun. It does not take progress into account since it doesn’t map well to Kitsun’s default intervals. I do still have a to-do on my list to check whether the progress can be calculated somehow, but right now it’s a bit low priority compared to other features.

One of those priority features being a revamp to the knowledge base as it is very outdated by now, which explains why you couldn’t find information about it. Sorry about that.

In general: Is anyone else experiencing these issues with the anki imports? Please let me know if so!

@Neicudi Couldn’t figure out how to send a PM, but the deck isn’t private, just my Genki vocab. Here’s the .apkg file:

Here’s the setting for the new scheduler that I had enabled:


It looks like the inner structure of the deck has changed due to the new scheduler functionality. The deck you’ve linked above does give me the same error and upon inspecting it seems that the database of the deck is structured differently.

After a quick google I found out that even the anki android app itself currently does not support decks which were exported with the new scheduler functionality enabled (Edit: it apparently does now). The source said that you can untoggle the feature and try to export the deck again, so perhaps that might work for you?

If you have the source of the deck (before you opened it with anki (and it transformed the deck to the 2.1 beta standard)) you could also try if that imports into Kitsun instead. Currently all popular shared decks from ankiweb still use the regular format and should work for importing into Kitsun.

That said, I will be making changes to the import in Kitsun when the 2.1 scheduler feature goes out of beta (to prevent having to change it whenever they make a breaking change, considering it’s marked as beta) in order to support those newly formatted decks as well.